Bug Report

(Resolved) KGSWishlist/Social bug [#1961]

Back to forum

New reply

tapir: (Resolved) KGSWishlist/Social bug (2009-09-10 22:22) [#6365]

If you edit the wishlist both save and preview substitute your entry with "no content" mark. This is nasty.

X Re: KGSWishlist/Social bug (2009-09-07 13:30) [#6367]

yea =\ was trying to add something and everything dissapeared. So i went back, copied the original, tried editing again and pasting the entire thing as it once was and now it doesn't work =\

reply ((no subject)) (2009-09-07 13:38) [#6368]

Also, you can add up to the "== [13] chat handling/room use ==" but no more (pasted original, deleted everything after the [13] ) and it worked. Adding anything more than that doesn't work.

EDIT: I've added everything up to the 13.

tapir: Re: ((no subject)) (2009-09-07 13:40) [#6369]

well, don't panic. it should not be necessary to re-add it by hand, there is a revive function - which doesn't work though. A job for MortArno...

PeterHB: Unable to reproduce problem (2009-09-10 02:31) [#6373]


I have been unable to reproduce this problem. You will see that I have edited KGSWishlist/Social, once with full page edit and once with the edit link that just brings up a section. To my perception, they have both worked okay.

If it is a 100% of the time repetitive problem, please could you add detail describing how to make it happen.

I have also tested the revive function, admittedly with my homepage PeterHB, rather than with KGSWishlist/Social, and it also appears to work fine, to my perception.

Obviously, I could be wrong/misunderstanding things, so don't feel too knocked back that I can't re-create it. When Arno gets the chance he may have more luck than me.

tapir: Re: Unable to reproduce problem (2009-09-10 09:30) [#6375]

look at herman's edit, i guess he didn't try to delete all content. the same happened to me. that the reviving function usually works is well known but i can't revive the full version here. (dunno, maybe related to page size / subpage behaviour) :(

HermanHiddema: Re: Unable to reproduce problem (2009-09-10 09:29) [#6376]

It seems that SL is currently unable to save a page longer than 64kb. As soon as I bring the content under 65 kb, it works fine.

For now, I'll split the page, but this is an issue that needs to be fixed by Arno, there's nothing we can do about it as librarians.

tapir: Re: Unable to reproduce problem (2009-09-10 09:32) [#6377]

well, a flag allowing bigger size which can be set for the 2-3 big pages may resolve the problem.

HermanHiddema: Re: Unable to reproduce problem (2009-09-10 09:36) [#6378]

It used to work, the version as saved by derPlumps was longer than 64k. I think it's just a bug, and Arno will fix it when he has time :)

tapir: Re: Unable to reproduce problem (2009-09-10 09:39) [#6379]

I had the same thought after taking another look in the version history. Maybe it is not the total length of the page which causes problems but the capacity of the editor.

HermanHiddema: Re: Unable to reproduce problem (2009-09-10 09:44) [#6380]

Well, there is the Large Editing Test Page, but I don't think any modern browser should have a problem editing 64kb. Also, if they did, then they would normally still edit (and save) the first 64kb, but in this case the whole page disappears.

Unkx80: Large Editing Test Page (2009-09-10 09:57) [#6381]

Dear all, there is this Large Editing Test Page. When I did the test, the result is "no content". Windows XP, Firefox 3.5.2 or Internet Explorer 8.0. Is this what you guys get too?

Edit: I should say that "no content" is the wrong result.

HermanHiddema: Re: Large Editing Test Page (2009-09-10 09:55) [#6382]

Yep, same thing here. Preview shows "no content" for the page, and also puts "no content" in my edit textarea

tapir: Re: Large Editing Test Page (2009-09-10 10:00) [#6383]

Firefox 3.5.2, MacOSX, same result - this is most probably not browser- or system-specific.

PeterHB: Re: Large Editing Test Page (2009-09-10 10:30) [#6384]

Yes, I have got the same 'no content' result as the rest of you. So it seems reasonable that this >64kb issue is what has affected tapir on the KGSWishlist/Social page. Re: Large Editing Test Page (2009-09-10 20:29) [#6385]

Phelan: Just confirming, same result here, with a similar system setup to Unkx80. (Forgot to sign in...)

fwiffo: Re: Large Editing Test Page (2009-09-10 20:53) [#6387]

I get the _no content_ thing. Firefox 3.5 on Linux.

ArnoHollosi: fixed (2009-09-10 22:05) [#6388]


A recent PHP update introduced a new default limit on submited data of 65KB. I've now increased the limit to 1MB. The largest page on SL is currently 174KB, so we should be on the safe side.

Back to forum

New reply

[Welcome to Sensei's Library!]
Search position
Page history
Latest page diff
Partner sites:
Go Teaching Ladder
Login / Prefs
Sensei's Library